Typing in Premiere Pro

I’m working on a clip in premiere pro I added lots of Hebrew text, but now when I want to add text in english it only types itself in Hebrew. Any idea why?

is your keyboard changed back to english?
otherwise i would save and reopen the project and try again

Yes, its changed back.
Already tried closing and reopening…

hmmm, on preferences make sure its set to english and typing left to right.

i dont see type prefernces in premiere

It is right…

not sure then, maybe try chat with adobe?

thanks for your help!

try hitting alt+shift

or uninstalling and reinstalling the program

if I do alt+ shift it just opens the markers window.
though i can try uninstalling and reinstalling

adobe will prob tell you that its a bug in the latest update if you have CC so will prob help to uninstall like adina said!