The text in the red boxes isn’t showing up automatically on page 2 - what did I do wrong?

Sounds like it wasn’t set up as a header and footer. When creating the table, there is an area for setting up a header/footer. With the table already selected, you can select the row and right click > select “convert to header”.