Hebrew in Adobe

I’ve been having a problem with hebrew in Adobe programs… it always comes out backwards when I copy and paste, or type, in hebrew.

Does anyone know how I can fix this?


Try preferences - type - click ‘Show Indic options’ - but I think this only works in illustrator

in the paragraph option, click the hamburger flyout menu and choose adobe world ready (send option)


You need to make sure your Indesign supports Hebrew. To download the Hebrew-supporting version, go into Creative Cloud, change your profile preferences in the app section to English תומך עברית (See image) , then re-install Indesign. (You should probably uninstall your old one first). Then you just have to make sure all your text is using the Adobe World-Ready Paragraph Composer setting (as suggested above). Then make sure, in your character panel, that all characters are on the “default” setting instead of right-to-left or left-to-right. (You’ll find that in the hamburger menu on the character panel.)

Good luck! Those problems can be really annoying. :slight_smile: